Leads API timeouts when reading leads

Incident Report for Auto Trader

Resolved

This issue is now resolved. We apologise for any inconvenience caused.
Posted Apr 01, 2025 - 16:03 BST

Identified

We are investigating an issue that may result in a 504 error when retrieving leads from our API. We have identified the likely cause and are actively working on a fix.
Posted Apr 01, 2025 - 14:03 BST
This incident affected: Production API Services (Image API, Taxonomy API, Vehicle API, Stock API, Search API, Valuations API, Historic Valuations API, Future Valuations API, Vehicle Metrics API, Leads API, Insurance Valuation Service) and Non-Production API Services (Taxonomy API Preproduction, Image API Preproduction, Vehicle API Preproduction, Stock API Preproduction, Search API Preproduction, Valuations API Preproduction, Historic Valuations API Preproduction, Future Valuations API Preproduction, Vehicle Metrics API Preproduction, Leads API Preproduction, Insurance Valuation Service Preproduction).