Performance degraded across multiple APIs

Incident Report for Autotrader

Resolved

This issue is now resolved. We apologise for any inconvenience caused.
Posted May 24, 2026 - 03:13 BST

Investigating

Our monitoring has detected a performance/stability issue impacting the following components: Finance API, Finance API Preproduction. Our engineers are investigating and will provide updates as soon as possible.
Posted May 24, 2026 - 03:03 BST