Uncached Vehicle Lookup Errors
Incident Report for Auto Trader
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 00:48 GMT
Investigating
We are aware there are currently issues performing lookups for vehicles that have not been previously searched. Engineers are investigating and will provide an update where necessary.
Posted Nov 03, 2023 - 00:38 GMT